Autor Wątek: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW  (Przeczytany 8128 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline Privalov

  • Junior Developer
  • Narybek
  • *
[impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« dnia: Październik 02, 2010, 12:43:24 pm »
Zaglądam tu po bardzo długiej przerwie, bo w międzyczasie otrzymałem już szereg listeli w sprawie takiej, że wtyczki, które dawno temu napisałem (impKonnekt i utlWycinek) nie chcą działać z nowymi wersjami WTW.

A że znalazłem w końcu chwilę czasu, by się temu znowu przyjrzeć, to spróbowałem zmusić je do tego, by znowu działały. Nie mogę jednak obiecać, że będę z nimi robił cokolwiek jeszcze poza tym (to uwaga głównie do utlWycinek, bo impKonnekt jako tako ma kompletną funkcjonalność w zakresie tego, co ma robić), więc tym razem postanowiłem spakować wtyczki wraz z kodami źródłowymi. Tak, są one napisane dość nietypowo, bo w asemblerze - zdaję więc sobie sprawę, że przydatność tych źródeł też może być niewielka. Ale gdyby się trafił jakiś pasjonat, to może się pobawić - w pakiecie jest też szablon czystej wtyczki.

Cały pakiet dostępny jest pod adresem:
http://flatassembler.net/other/asmWTW.zip

przy czym na razie niestety przetestowałem tylko wersje 32-bitowe. Zatem wtyczyki z podkatalogu "x64" mogą z dużym prawdopodobieństwem nie działać lub działać bardzo nieprawidłowo - z góry ostrzegam. Z drugiej strony, gdyby znalazł się ktoś, kto by mógł 64-bitowe wersje mi przetestować, byłbym wdzięczny.

Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #1 dnia: Październik 02, 2010, 19:25:37 pm »
Co prawda nie testowałem ultWycinek wcześniej ale jak chcesz to mogę przebadać wersję 64-bitową

Offline Aloiz

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #2 dnia: Październik 03, 2010, 20:46:24 pm »
Chciałem zgłosić, że [utlWycinek] działa elegancko z  najnowszą wersją WTW.
Dzięki wielkie :)

Offline tommy_be

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #3 dnia: Październik 27, 2010, 15:44:01 pm »
Niestety [impKonnekt] w wersji x64 nie działa - na starcie programu dostaję info:
Cytuj
Wtyczka (C:\Program Files....\impKonnekt.plug) jest za stara (jej struktura wtwPluginInfo ma nieprawidłowy rozmiar), prosze uaktualnić lub usunąć;

Przy okazji mam pytanie - jeśli zaimportuję sobie historię konnekta do wtw na systemie 32bit i skopiuję plik database.sq3 do odpowiedniego katalogu na systemie 64bit to jest szansa, że taka hybryda ruszy?

Edit: ok, pytania nie było - przeprowadziłem próbę na żywym pacjencie i wszystko działa - przynajmniej jak do tej pory.
« Ostatnia zmiana: Październik 27, 2010, 15:56:04 pm wysłana przez tommy_be »

Offline Bard

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #4 dnia: Styczeń 02, 2011, 17:48:48 pm »
U mnie niestety to samo, wtyczki nie działają dostaję identyczny komunikat jak kolega wyżej :(

Offline Facillis

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #5 dnia: Czerwiec 19, 2011, 17:16:28 pm »
Działa to komuś i gdzie znaleźć opcje tej wtyczki. Mam ja uruchomioną ale nigdzie nie mogę znaleźć jej funkcji. Zależy mi na tym ponieważ kilka lat korzystałem z konnekta a dziś mnie coś tknęło aby się przesiąść na coś innego.

Offline emilio

  • Stylista
  • Młodzież
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #6 dnia: Czerwiec 19, 2011, 19:56:09 pm »
Facillis
Też Cię witam!
Chyba chodzi Ci o wtyczkę impKonnekt, jakiś czas temu działała (teraz nie jestem pewien, minęło trochę czasu odkąd jej używałem), a opcji jej nie potrzeba, wystarczy kliknąć: narzędzia > archiwum > konserwacja > import i tam znajduje się to czego szukasz.
Jeśli chodzi o utlWycinek to lepiej zainteresuj się wtyczką utlImage jest o niebo lepsza i działa jak należy.
________________________________________________________________________________

Offline zhvir

Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #7 dnia: Czerwiec 19, 2011, 20:22:34 pm »
emilio mylisz import wbudowany w wtw z wtyczką
btw obecnie wtyczka nie działa
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline Facillis

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #8 dnia: Czerwiec 19, 2011, 20:56:06 pm »
Dzięki Wam za informacje, jeżeli chodzi i impKonnekt to faktycznie nie działa. Czy są inne sposoby aby przenieść dane z konnekta do wtw-czy pozostaje się pożegnać lub dalej pozostać przy konnekcie?

Offline zhvir

Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #9 dnia: Czerwiec 19, 2011, 21:00:06 pm »
zainstaluj tymczasowo którąś z wczesnych wersji wtw (tu masz wersje z końca 2009 roku http://minefield.k2t.eu/archive/wtf/ ) i użyj powyższej wtyczki, po udanym imporcie uaktualnij wtw do najnowszej wersji

Uwaga! downgrade na własne ryzyko ;)
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline Facillis

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #10 dnia: Czerwiec 19, 2011, 21:37:36 pm »
"Uwaga! downgrade na własne ryzyko ;)" tzn z czym może się to wiązać?
Jeszcze całkowicie nie przesiadłem sie na wtw ale dopiero rozpoznaję jego możliwości.

Offline zhvir

Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #11 dnia: Czerwiec 19, 2011, 21:44:48 pm »
może się coś stać, ale co to nikt tego nie wie póki nie sprawdzisz
zawsze najpierw możesz sprawdzić na osobnej instalacji starej wersji wtw czy wtyczka zadziała (a powinna)
a z downgradem aby mieć wszystko w jednym archiwum to już sam ryzykujesz... bo wiesz, to jest jednak spora różnica czasowa i na pewno wiele rzeczy się pozmieniało, więc nie wiadomo jak wtw zareaguje na downgrade i ponowny upgrade

jak sprawdzisz to nam napisz ;)
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline Facillis

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #12 dnia: Czerwiec 19, 2011, 22:17:19 pm »
Ściągnąłem już kilka rożnych wersji z kilku różnych miesięcy i w każdej mi wyskakuje brak funkcji API. Nie wiem gdzie może leżeć przyczyna?

Offline zhvir

Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #13 dnia: Czerwiec 19, 2011, 22:23:43 pm »
osobiście sprawdziłbym wersję z okolic października 2010 (czyli tak jak został założony ten wątek)
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline Spirit72

  • Narybek
  • *
Odp: [impKonnekt] [utlWycinek] - dostosowanie do aktualnej wersji WTW
« Odpowiedź #14 dnia: Czerwiec 02, 2012, 07:56:03 am »
Witam
Pisze jak sobie poradzilem z przniesieniem arhiwum konekta do wtw  uzywam programu wtw portable build may 22 2012  3366   windows 7 64   wiec mialem problemy jak wszyscy  na systemie 64 wywalalo blad wiec zrobilem test i odpalilem wtw na profilu 32bitowym i wtedy wtyczka wszystko przeniasla pozostalo skopiowanie pliku archiwum do profilu na 64 i po sprawie