Autor Wątek: [wtwRegexReplacer] Nie działa.  (Przeczytany 5136 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
[wtwRegexReplacer] Nie działa.
« dnia: Czerwiec 10, 2010, 21:08:07 pm »
Nie mam pojęcia co źle robię. Z początku ta wtyczka wydawała mi się zbędna, ale widzę wiele zastosowań i sam sobie dopiszę chętnie inne (podzielę się oczywiście ;]). Wrzucam xml w "Otwórz lokalizację profilu" z Menu głównego + w userTheme + "Otrwórz lokalizację WTW" bo już nie mam pojęcia gdzie. Wtyczka włączona w opcjach i nic nie działa. Nadal wyświetla zwykle linki do obrazków i do youtuba. Może ktoś przygotować paczkę z gotowym układem katalogow, albo jakoś pomóc? Win 7 x64

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #1 dnia: Czerwiec 10, 2010, 21:17:08 pm »
Ja mam to tak zrobione :
C:\Program Files\K2T\WTW\Plugins\wtwRegexReplacer.plug
C:\wtw-profiles\demon\wtwRegexReplacer.xml

Zamiast demon, nazwa Twojego profilu. xP
Tylko ja mam Viste x86... nie mam w domu systemów x64(z nimi są ciągle problemy, tak jak z vistą) ;/

PS: na foldery: wtw-profiles oraz K2T dałem prawa administratora x]
może w tym sęk?
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #2 dnia: Czerwiec 10, 2010, 21:38:26 pm »
no dobra ale Ty masz wydzielony jakoś katalog profilu (przy instalacji masz taki wybór), a ja po prostu mam
C:\Users\Piotr Świtalski\appdata\roaming\.wtw\profiles\piotr świtalski

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #3 dnia: Czerwiec 10, 2010, 22:03:11 pm »
Kolego.. na początku pokazało mi opcje.. które  skrupulatnie Sprawdziłem...
Gdzie ja się będę po takich ścieżkach plątał ? :P

W takim razie tutaj zamieść plik xml :
C:\Users\Piotr Świtalski\appdata\roaming\.wtw\profiles\piotr świtalski\wtwRegexReplacer.xml

Sprawdź uprawnienia Userów dla katalogu .wtw(tak na wszelki wypadek  - u mnie na vista było to wymagane ;/)

Win 7 sprawdzę za jakiś czas..jak wykonam kopie danych z Visty.
Ale nie pale się do tego x]
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #4 dnia: Czerwiec 10, 2010, 23:05:13 pm »
To nie kwestia uprawnień. Nie wiem w czym rzecz, ale wtyka nie działa :P

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #5 dnia: Czerwiec 10, 2010, 23:57:09 pm »
kodowanie dobre? co konsola krzyczy?

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #6 dnia: Czerwiec 11, 2010, 06:36:52 am »
Notepad++
Nie wiem czy to wersja pod x64, ale ja bez tego jak bez ręki.

W razie czego masz tutaj plik xml z kodowaniem UTF-8 (bez BOM) : wtwregexreplacer.zip (0.55 KB)
Więcej jak to odpalić tutaj.
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline Ivek88

  • Narybek
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #7 dnia: Czerwiec 11, 2010, 07:24:28 am »
Zobacz czy masz zainstalowanego flash playera najnowszego pod IE.
Ja mam xp 32 więc, nie nie mam jak sprawdzić, ale zacznij od tego.
Jeśli nie pomoże to spróbuj zainstalować WTW normalnie do program files i tam, żebyś miał katalog z profilem.
Może wtyczka ma wpisaną ścieżkę i przez to nie hula jak powinno :p

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #8 dnia: Czerwiec 11, 2010, 07:38:57 am »
próbuj zainstalować WTW normalnie do program files i tam, żebyś miał katalog z profilem.
Wybór miejsca lokalizacji profilu wybiera się z początku przy tworzeniu profilu..
Nie pamiętam dokładnie jak to było..
Ale daje chyba 3 możliwości:
1.) Tam gdzie program zainstalowany(czyli: Program Files)
2.) Tam gdzie kolega posiada(czyli w AppData)
3.) I wybrać miejsce lokalizacji np Pen drive (ja wybrałem C:\ )

A sam program się w standardzie instaluje w Program Files, chyba że ręcznie się coś zmieni podczas instalacji x]

Nie wiem czy można od kopa zmienić lokalizacje profilu.
I tez nie wiem czy lokalizacja ma wpływ na działanie Wtyczek, plus polskie znaki w profilu x]

Ciekawe co konsola pokaże.
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #9 dnia: Czerwiec 11, 2010, 10:34:01 am »
Ja bez notepada++ też jak bez ręki... jest UTF-8 bez BOM, więc to nie to. A flash najnowszy nie miałby chyba wpływu na pokazywanie obrazków z linków. Adrian co konkretnie mam wstukać w konsole, albo co przesłać, bo konsolowe podejście ala Linux jest mi obce :P


Aaa... mam tak:
[121424::wtwRegexReplacer] can't load file

Offline Vimes

  • Global Moderator
  • Starszyzna
  • *
  • Nie tak zaraz ten ambaras
    • http://sirsamvimes.deviantart.com/
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #10 dnia: Czerwiec 11, 2010, 22:51:41 pm »
Zamieść tu XML jako załącznik dokładnie taki jak wrzucasz w "lokalizację profilu" . A do UTF-8 można zapisać windowsowym notatnikiem.
Zanim napiszesz poszukaj PEBKAC!
Tutaj  piszę o fotografii
Kiedy myślisz ze natknąłeś się na dno dna i niżej już nic nie ma zawsze zjawia się koleś z łopatą

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #11 dnia: Czerwiec 11, 2010, 23:08:46 pm »
Mam jeden z tych gotowych w dziale "Dodatki" "Gotowe wyrażenia Regrex...". Nie chcesz go widzieć :P Inaczej... jeżeli Tobie działa jakiś to wyślij mi tu zawartość, albo na priv.

Chcę widzieć żeby wiedzieć z czego wynika błąd //Vimes
« Ostatnia zmiana: Czerwiec 11, 2010, 23:23:19 pm wysłana przez Vimes »

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #12 dnia: Czerwiec 11, 2010, 23:40:05 pm »
Aaa... mam tak:
[121424::wtwRegexReplacer] can't load file
nie może załadować pliku hmmm ;]
<?xml version="1.0" encoding="utf-8"?>
<wtwRegexReplacer>
<item regex="(abc)" format="cba atakuje!" ignoreCase="1"/>
</wtwRegexReplacer>
jak to nie zadziała to wina lokalizacji profilu, lub uprawnień? x]
Z Vista miałem jaja do póki nie nadałem prawa folderowi K2T, a już nie wspomnę o profilu xP
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline refresh

  • Grammarnazi
  • Global Moderator
  • Starszyzna
  • *
  • Ciasteczkowy Potwór :3
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #13 dnia: Czerwiec 12, 2010, 10:12:21 am »
deklaracja pliku może sobie być, ale o ile nie zapisze się do utf8 bezpośrednio w notatniku i tak czytać nie będzie (próbowałem wcześniej w n++ to zrobić i też miałem ten problem).

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #14 dnia: Czerwiec 12, 2010, 11:58:26 am »
ale o ile nie zapisze się do utf8 bezpośrednio w notatniku i tak czytać nie będzie (próbowałem wcześniej w n++ to zrobić i też miałem ten problem).
Ciekawe próby ;)
Chyba nie poddałeś pliku konwersji ;)
Bez konwersji wywala różne błędy, licząc skrypty php :P
Poza tym ja np mam N++ ustawionego na stałe z formatowaniem UTF-8 (bez BOM),
ze zwykłym UTF-8 ma błędy w php ;P

Jednak przeprowadziłem test, utworzyłem plik xml w standardzie na ANSI, zapisałem jako wtwRegexReplacer.xml
Tego już plugin nie odczyta ;]
Ale poddałem plik konwersji na UTF-8 (bez BOM) i wszystko śmiga jak należy :)

Ale wracając do tematu.
@switalski.piotr, próbowałeś Zmienić lokalizacje profilu?
Plus może usuwając przy tym np polskie znaczki w nazwie profilu ?
może z tym jest problem że nie może załadować ścieżki do pliku xml?
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline Vimes

  • Global Moderator
  • Starszyzna
  • *
  • Nie tak zaraz ten ambaras
    • http://sirsamvimes.deviantart.com/
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #15 dnia: Czerwiec 12, 2010, 12:47:21 pm »
Mówiłem że chcę zobaczyć jego plik bo obstawiam że nie ma UTF8.
Przypomina mi się problem z podkreślaniem pisowni - gdzie użytkownik nie miał tego włączonego...
Zanim napiszesz poszukaj PEBKAC!
Tutaj  piszę o fotografii
Kiedy myślisz ze natknąłeś się na dno dna i niżej już nic nie ma zawsze zjawia się koleś z łopatą

Offline refresh

  • Grammarnazi
  • Global Moderator
  • Starszyzna
  • *
  • Ciasteczkowy Potwór :3
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #16 dnia: Czerwiec 12, 2010, 13:55:36 pm »
@DemoNCS na N++ działam na co dzień i o konwersji nie zapomniałem ;) no ale było minęło, mi już działa, zapisywałem w zwykłym notatniku :P

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #17 dnia: Czerwiec 12, 2010, 14:05:42 pm »
@switalski.piotr : pobierz plik : test-wtwregexreplacer-xml-utf8.zip (0.27 KB)
I go przetestuj ;)

U mnie to tak wygląda po wpisaniu test :


@refresh, daj mi ten niedziałający plik :)
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #18 dnia: Czerwiec 12, 2010, 18:12:29 pm »
Ok. Po skończonym projekcie z teorii sprężystości na pewno sprawdzę :) A co do UTF-8 to na pewno nie... pracuję w N++ od kilku lat pisząc strony, więc UTF-8 bez BOM jest na 100%. Chyba, że jest tak jak Fresh mówi. A w notatniku jak ustawić konwersję tak btw? Jako pierwsze przetestuję Twój plik. A co do nazwy profilu to fakt... mam Ś. Ale to byłby problem?

Offline DemoNCS

  • Młodzież
  • **
  • Maniak IT
Re: [wtwRegexReplacer] Nie działa.
« Odpowiedź #19 dnia: Czerwiec 12, 2010, 18:17:06 pm »
A co do nazwy profilu to fakt... mam Ś. Ale to byłby problem?
Gdzieś na Forum, ktoś miał też w nazwie profilu pl znaczek..
też mu wtyczki nie działały(albo jedna) ;)
Dopiero po zmianie napisał że wszystko jest ok i działa.

Więc warto sprawdzić ;)
Ehhh re-up avka nie działa (błąd zapisu załącznika) :(