Autor Wątek: Problem z kompilacją wtwPlugTemplate  (Przeczytany 1592 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline amras

  • Narybek
  • *
Problem z kompilacją wtwPlugTemplate
« dnia: Październik 16, 2010, 16:13:30 pm »
Win 7 x32, VC++ 2008 SP1, api 20101011 w katalogu.
Podczas  wtyczki wywala:

wtwplugtemplate\api\wtwlog.h(88) : error C3861: '_vsnwprintf': identifier not found

Zieleń ze mnie bije... więc pomocy :)

Offline kwiateusz

Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #1 dnia: Październik 17, 2010, 10:18:53 am »
w stdinc.h pod #include <windows.h> dodaj #include <stdio.h>

Offline amras

  • Narybek
  • *
Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #2 dnia: Październik 17, 2010, 11:05:11 am »
nie pomogło, tymczasowo obchodzę problem wykomentowując fragment kodu w wtwlog.h - i tak nie używam tych funkcji.

Offline kwiateusz

Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #3 dnia: Październik 17, 2010, 11:29:25 am »
u mnie działa acz na 2010

Offline sWirus

Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #4 dnia: Październik 17, 2010, 11:32:16 am »
to dodaj to
#include <stdio.h>
 do wtwLog.h ;p
Oblałem test Turinga... damn ;/

Offline amras

  • Narybek
  • *
Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #5 dnia: Październik 17, 2010, 11:47:19 am »
poszło, dzięki

Offline kwiateusz

Odp: Problem z kompilacją wtwPlugTemplate
« Odpowiedź #6 dnia: Październik 17, 2010, 17:56:03 pm »
przy aktualizacji api sie nadpisze... ja mam w stdinc.h przed #include <plInterface.h> i działa