Autor Wątek: [Emots] - emotikony w WTW  (Przeczytany 236972 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #40 dnia: Czerwca 13, 2009, 23:10:39 pm »
no wlasnie to nie jest takie proste jaby wydawac sie moglo :P

//edit
i wlasnie zauwazylem bol w feature pack, bo std::tr1::regex nie wspiera perl'owskich wyrazen, a boost::regex tak (jako default nawet) a tam problem latwo daloby sie rozwiazac za pomoca lookback'a.... trzeba bedzie nad tym pokombinowac... ale jak na razie, trzeba radzic sobie z tym co jest - za tydzien sesja....
« Ostatnia zmiana: Czerwca 13, 2009, 23:35:28 pm wysłana przez adrian_007 »

Offline zhvir

Re: Emots
« Odpowiedź #41 dnia: Czerwca 14, 2009, 11:59:16 am »
« Ostatnia zmiana: Czerwca 14, 2009, 21:25:55 pm wysłana przez zhvir »
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline Jarson

  • Młodzież
  • **
Re: Emots
« Odpowiedź #42 dnia: Czerwca 14, 2009, 16:59:52 pm »
Śmiga jak należy - testuję na Windows Vista Home Premium SP1 64bit PL
http://wtw.k2t.eu/
Widziałeś Nowe WTW?

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #43 dnia: Czerwca 14, 2009, 18:35:44 pm »
no, to teraz przynajmniej kilku 64-bitowcow bedzie zadowolonych :P

i sie powtorze, serio fajnie byloby miec porzadna paczke z emotami gg6.0 :P:P:P

Re: Emots
« Odpowiedź #44 dnia: Czerwca 14, 2009, 18:48:19 pm »
i sie powtorze, serio fajnie byloby miec porzadna paczke z emotami gg6.0 :P:P:P
no tworze, tworze, ale napotkalem male problemy :)
brak ogonków? alt mi wypadł

Re: Emots
« Odpowiedź #45 dnia: Czerwca 14, 2009, 21:42:44 pm »

?

Jest tak przy obu dostępnych setach, a także przy przykładowym od adriana.

Vista x64.
« Ostatnia zmiana: Czerwca 14, 2009, 21:45:48 pm wysłana przez buttie »

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #46 dnia: Czerwca 14, 2009, 22:17:51 pm »
cos ja widze, ze ten parser xml od microsoftu ssie....

Re: Emots
« Odpowiedź #47 dnia: Czerwca 15, 2009, 06:54:25 am »
Na XP SP3 z IE8 działa (po instalacji Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) oczywiście).

Czy problem na x64 może sprawiać IE8?

Najlepiej jest jednak zupełnie bez żółtych mord. ;)

Offline zhvir

Re: Emots
« Odpowiedź #48 dnia: Czerwca 15, 2009, 15:52:34 pm »
u mnie wszystko w porządku, żadnych dziwnych komunikatów nie doświadczyłem

winx64 + ie8 + MSVC++2008SP1
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #49 dnia: Czerwca 15, 2009, 16:57:42 pm »
ogolnie, to w nastepnej wersji bedzie zmieniony parser xml na ten co siedzi w wtw, takze powinno to rozwiazac problem, ale to zapewne dopiero na poczatku lipca :P

Re: Emots
« Odpowiedź #50 dnia: Czerwca 16, 2009, 20:34:01 pm »
Teraz już nic nie kumam. Wrzuciłem nową nightly i mordy się teraz wczytują. Dla testów zrobiłem więc rollback do bety i... wczytują się nadal.

Pomyślałem, że może to ja jakiś głupi jestem ;) więc sprawdziłem na Win7 x64.
Zachowanie identyczne, beta - nie wczytują się, nightly - wczytują, rollback do bety - wczytują.

Przez ostatnie 2 tygodnie nie instalowałem żadnego nightly i podejrzewam, że w nocnych buildach było coś czego beta nie ma. Nie chce mi się jednak robić clean-installi żeby to sprawdzić.

Edyta: Po restarcie systemu emoty się nie wczytują ponownie. Pomaga reinstalacja wtw, aż do następnego restartu... Błąd występuje tylko w systemach x64, zarówno w Viście jak i Win7.
« Ostatnia zmiana: Czerwca 17, 2009, 10:00:44 am wysłana przez buttie »

Offline alberht

  • WTW evangelist
  • Global Moderator
  • Młodzież
  • *
    • http://forum.k2t.eu/
Re: Emots
« Odpowiedź #51 dnia: Czerwca 16, 2009, 23:35:11 pm »
proponuję stworzyć jeden plik z wyrażeniami regularnymi zawierający najpopularniejsze emotki (które to kwestia do dogadania) aby ułatwić tworzenie nowych zestawów - łatwiej podmienić gify niż myśleć nad wyrażeniami;)
Regards,
alberht
WTW evangelist

Offline zimaq

Re: Emots
« Odpowiedź #52 dnia: Czerwca 21, 2009, 12:52:09 pm »
Jakby wtyczka nie zamieniała znaków w linku na emotki było by słitaśnie.
I nie, nie chodzi o rozwiązanie po stronie zestawu emotikonów, przez ustalenie, że przed emotką ma być spacja.

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #53 dnia: Czerwca 23, 2009, 17:26:42 pm »
0.3.0.1
 ** dodane optymalizacje - teraz dziala szybciej
 ** zmieniony sposob ladowania xml (kodowanie ma byc podane na samym poczatku pliku)
 ** naprawiony blad z >p => ;p i tym podobne
 ** workaround na linki i :/ => dziala dla http://google.com ale juz dla http://google.com?search=:/ nie koniecznie :P
 ** polskie znaczki powinny dzialac jak trzeba
 ** jeszcze jakies rzeczy, o ktorych zapomnialem, ale wiem, ze sa zrobione :P

http://www.adrian12.w.tkb.pl/wtw2/emots/

Offline zhvir

Re: Emots
« Odpowiedź #54 dnia: Czerwca 23, 2009, 18:31:06 pm »
** zmieniony sposob ladowania xml (kodowanie ma byc podane na samym poczatku pliku)

a mogę prosić jakiś przykład?
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #55 dnia: Czerwca 23, 2009, 18:46:45 pm »

Offline zhvir

Re: Emots
« Odpowiedź #56 dnia: Czerwca 23, 2009, 18:53:57 pm »
** polskie znaczki powinny dzialac jak trzeba

Przez te polskie znaczki to mi pokazywało komunikat że ne można załadowaćzestawu xml :P
niemniej dobrze bo znalazłem błąd w wyrażeniu który powodował niewczytywanie zestawu...
<całus>  ....przez literke "ł"  :P

w związku z tym czy powinienem xml zakodować do utf-16 żeby mi polskie znaki chadzały?
a jeśli proponujesz żeby jednek kodować w utf-8 to jak sie ma to do twojego zdania z changelogu??

---

a teraz coś z zupełnie innej beczki...



powyżej widzimy rezultat zmiany zestawu emotikon bez restartu komunikatora... hehe przyjamna sprawa
i teraz moja propozycja:
możliwość ładowania osobnych zestawów emotikon w zależności od sieci natomiast dla metakontaktów przeładowywanie zestawu w zależności z którym podkontaktem z której sieci w danym momencie piszemy

« Ostatnia zmiana: Czerwca 23, 2009, 19:12:42 pm wysłana przez zhvir »
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline adrian_007

  • Moderator
  • Starszyzna
  • *
    • WTW PLUGINS
Re: Emots
« Odpowiedź #57 dnia: Czerwca 23, 2009, 20:39:19 pm »
« Ostatnia zmiana: Czerwca 23, 2009, 20:51:02 pm wysłana przez adrian_007 »

Offline Vimes

  • Global Moderator
  • Starszyzna
  • *
  • Nie tak zaraz ten ambaras
    • http://sirsamvimes.deviantart.com/
Re: Emots
« Odpowiedź #58 dnia: Czerwca 23, 2009, 20:42:05 pm »
Ja jak znajdę chwilę to przerobię mój zestaw z tlena oparty o zestaw Denu ale mam wrażenie że szybko tego nie zrobię bo to duuuuuży zestaw i jak sobię pomyślę że zabieram się za wszystko pojawi się pomysł żeby go troszkę odchudzić. I tu się pojawia jednostka czasu w których pracuje ten komunikator: EON.
Ale jak mi się uda coś zrobić podzielę się ;)
Zanim napiszesz poszukaj PEBKAC!
Tutaj  piszę o fotografii
Kiedy myślisz ze natknąłeś się na dno dna i niżej już nic nie ma zawsze zjawia się koleś z łopatą

Offline Dimension

Re: Emots
« Odpowiedź #59 dnia: Czerwca 24, 2009, 12:55:39 pm »
« Ostatnia zmiana: Czerwca 24, 2009, 12:57:33 pm wysłana przez Dimension »