Autor Wątek: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?  (Przeczytany 17486 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline wujek_bogdan

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #40 dnia: Grudnia 07, 2009, 18:50:05 pm »
No to tym lepiej, ewentualne błędy dotyczyć będą tylko okna rozmowy ;P
Standardowy styl powinien chyba jako tako działać na IE6.
gdyby IE6 poprawnie przetwarzał CSS, to nie było by problemu ;) Zobacz sobie np. na test ACID2, jak perfekcyjnie IE6 potrafi rozwalić layout. To czy styl będzie działać pod IE6 zależy od tego jak wygląda kod... a to jak wygląda kod i czy jest optymalizowany pod IE6 zależy od twórcy stylu.

Nie chodzi o style, a o to, że na IE6 lubi się czasem ot tak wyłozyć + nie działa często auto-scroll.
A to ciekawostka. btw, czy jest szansa, że w oknie rozmowy będzie można używać javascript? Nie widziałem w żadnym komunikatorze takiej możliwości, a mogło by to być całkiem ciekawe.

Offline luk47

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #41 dnia: Grudnia 07, 2009, 19:41:44 pm »
Mały OT, ale z ciekawości, jakie możliwości to daje? ;)
« Ostatnia zmiana: Grudnia 07, 2009, 20:32:30 pm wysłana przez zhvir »
Człowiek jest wolny całkowicie lub nie jest wolny wcale.

Offline wujek_bogdan

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #42 dnia: Grudnia 07, 2009, 20:18:21 pm »
większe możliwości personalizacji, chociażby dzięki użyciu prostych funkcji, warunków itd... albo ciekawsze rzeczy jak np. animacje dzięki jQuery, lub innym bibliotekom.

Offline Majaque

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #43 dnia: Grudnia 07, 2009, 20:48:14 pm »
Nie chodzi o style, a o to, że na IE6 lubi się czasem ot tak wyłozyć + nie działa często auto-scroll.
Trident IV jest naprawdę zabugowanym silnikiem, więc wcale się nie dziwię...

/offtop:
A to ciekawostka. btw, czy jest szansa, że w oknie rozmowy będzie można używać javascript? Nie widziałem w żadnym komunikatorze takiej możliwości, a mogło by to być całkiem ciekawe.
Akurat kompozycja Black Inspiration Java Script w AQQ ma taką możliwość.

Offline zhvir

Re: WTW a IE 7
« Odpowiedź #44 dnia: Marca 25, 2010, 19:25:35 pm »
1. czy youtuba też poprosisz o wyłączenie komunikatu nawołującego do zmiany przeglądarki na nowoczesną?
czy poczekasz aż zupełnie wyłączą możliwość uruchamiania pod ie6?
2. od trzymania trupa w postaci ie6 na dysku, pod którego strony piszą już tylko desperaci, wolałbym programik w stylu http://www.my-debugbar.com/wiki/IETester/HomePage
3. jeżeli bardzo się jednak upierasz przy opcji wyłączania komunikatu zrób sobie reverse engineering kodu i sam znajdź co trzeba przestawić
4. nie sądzę żeby Kaworu poszedł nawet na kompromis ;)
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Offline MaciaK

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #45 dnia: Marca 25, 2010, 20:11:01 pm »
hm na laptopie mam ie6 bo chce zeby szybko win chodzil i tak jest wiec nie chce zmieniac, a wystarczyla by opcja wylaczenia komunikatu z ostrzezeniem. Widzialem juz go i wiem ze moge spodziewac sie problemow ale zadnych jak narazie nie uswiadczylem i fakt ze komunikat wyskakuje jest ruwnie irytujacy jak reklama na starcie tlena. Naprawde opcja pokazuj bledy krytyczne nie zrobila by nikomu krzywdy ;p a sam jestem swiadom ze to zle ze mam nieaktualnego ie6 ale chce zeby tak zostalo.
« Ostatnia zmiana: Marca 25, 2010, 20:25:30 pm wysłana przez zhvir »

Offline Kaworu

  • Ryszard
  • Szlachta
  • *
  • Twój Koszmar Senny
    • k2t.eu
Re: WTW a IE 7
« Odpowiedź #46 dnia: Marca 25, 2010, 20:35:53 pm »
Cytuj
4. nie sądzę żeby Kaworu poszedł nawet na kompromis ;)
w zasadzie mógłbym dać taką możliwość, aaaale... znając użytkowników, wyłączą - nie bardzo nawet przeczytają treść, a potem będą marudzili na to, że przewijanie w oknie rozmowy nie działa. TAK były takie przypadki. So, jakbym dał możliwość wyłączenia tego pewnie natykałbym się na takich delikwentów jeszcze częściej. ;P

Edit: Ok, jak nie zapomnę to dodam taką opcję, ALE - przy okazji dorzucę jakiś wredny mechanizm, którym ją będzie można zablokować, i jak się objawi na forum albo na BT jakiś geniusz (albo może kilku) marudzący na cokolwiek powiązanego z IE6, to komunikat wróci.
« Ostatnia zmiana: Marca 25, 2010, 21:45:43 pm wysłana przez zhvir »

Offline zhvir

Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #47 dnia: Marca 25, 2010, 20:39:12 pm »
Kończąc moje wypowiadanie się w tym temacie powiem tylko, że macie wolną wolę i to jest wasz wybór czy zainstalujecie IE8, czy pozostaniecie na IE6, tylko nie zdziwcie się później jak wam wyskakują jakieś dziwne błędy w programie, w obsłudze emotek, czy w obsłudze stylów czata... i nie zdziwcie się jak będzie takich błędów coraz więcej, a dowiedziawszy się że macie IE6 nikt takiego zgłoszenia o błędzie nawet nie obejrzy ;) Jak już wcześniej gdzieś w którymś wątku wspomniałem moje style okna rozmowy nigdy na IE6 testowane nie będą i nie sądzę żeby chociaż połowa z nich wyświetlała się poprawnie... nawet jestem gotów tak przygotować kod żeby na IE6 wszystkie style się wykrzaczały)
Mój głos w kwestii tych powiadomień o starej wersji IE jest po części zbieżny z waszymi poglądami tzn. jestem przeciwny takim komunikatom, w związku z czym postuluję całkowite zablokowanie instalacji wtw na maszynach wyposażonych w IE6.

Pozdrawiam ^^
Chciałbym być zawsze niewinny i prawdziwy, chciałbym być zawsze pełen wiary i nadziei...

Re: WTW a IE 7
« Odpowiedź #48 dnia: Marca 25, 2010, 20:58:04 pm »
to moze lepiej zrobic, zeby wyskoczyl komunikat ale z nieaktywnym przyciskiem OK :) do tego 2 checkboxy, jeden "Przeczytalem, zrozumialem i zapamietalem", drugi "Nie pokazuj ponownie"
Po zaznaczeniu pierwszego, przycisk OK sie uaktywnia. Takie cudo chyba by bylo ok
brak ogonków? alt mi wypadł

Offline mocznik

  • Młodzież
  • **
    • deviantart
Re: WTW a IE 7
« Odpowiedź #49 dnia: Marca 25, 2010, 21:14:02 pm »
A może wyłączanie tego tylko za pomocą konsoli?
Wszystko co umieszczam na forum jest na licencji CC-BY-NC-ND 3.0

Offline Vimes

  • Global Moderator
  • Starszyzna
  • *
  • Nie tak zaraz ten ambaras
    • http://sirsamvimes.deviantart.com/
Re: WTW a IE 7
« Odpowiedź #50 dnia: Marca 25, 2010, 21:16:35 pm »
Wolę jednego marudzącego na okno niż setki na to że się nie przewija. Sorry ale IE6 jest trupem i należy napiętnować ludzi używających go!
Edit. A komunikat jest ciągle jeszcze za mały!
Mam inną propozycję. Czy nie dało by się zablokować uruchomienia WTW jeżeli nie ma IE > 6.  Tak jak to jest z SP2 w Win XP ?
Zanim napiszesz poszukaj PEBKAC!
Tutaj  piszę o fotografii
Kiedy myślisz ze natknąłeś się na dno dna i niżej już nic nie ma zawsze zjawia się koleś z łopatą

Offline Vimes

  • Global Moderator
  • Starszyzna
  • *
  • Nie tak zaraz ten ambaras
    • http://sirsamvimes.deviantart.com/
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #51 dnia: Marca 27, 2010, 17:08:50 pm »
Cytuj
1. Nie muszę o nic prosić. Mam FF 3.6.2 oraz Operę 10.50. Na kij mi nowszy IE? Czytanie ze zrozumieniem...?
2. Mam go (pobrałem, nie instalowałem, chyba usunę), ale po co instalować coś, co już mam na dysku w postaci IE6? IETab też próbowałem, ale lubi wysypać przeglądarkę.
To po co Ci w miarę aktualna Opera  można przecież używać 9.10 albo 9.26 albo po co Ci napalony lisek w najnowszej wersji(która nie jest zalecana przez mozillę) przecież mogłeś pozostać przy 2 ?
Zanim napiszesz poszukaj PEBKAC!
Tutaj  piszę o fotografii
Kiedy myślisz ze natknąłeś się na dno dna i niżej już nic nie ma zawsze zjawia się koleś z łopatą

Offline wujek_bogdan

  • Młodzież
  • **
Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #52 dnia: Marca 28, 2010, 08:03:06 am »
pisząc kod xHTML/CSS testuje się
- IE6, 7, 8
- Firefox
- Opere
- Chrome (ewentualeni Safari, Konqueror itp)
Z tym, że użytkownicy FF/Opery/itd mają skłonność do regularnego apdejtowania i raczej nie testuje się na starych wersjach, bo ich udział procentowy jest znikomy. A po drugie praktycznie nie ma różnic w renderowaniu stron przez FF/Operę w najnowszych i nieco starszych wersjach, w przeciwieństwie do IE.
Co prawda jest takie narzędzie jak IE tester, które ma wbudowane silniki IE 5.5/6/7/8, ale
1. potrafi się wysypać
2. jest już nierozwijanie
3. nie zawsze działa do końca poprawnie i zamula

Dlatego właśnie pracując w webdesignie warto mieć zabytek taki jak IE 6.0 na dysku. Są też wersje standalone, ale nie działa to do końca tak jak trzeba. Osobiście stosuję jednak inny zabieg - Virtualbox ;)

Offline bugmenot

  • Młodzież
  • **
Odp: Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #53 dnia: Stycznia 27, 2011, 16:08:27 pm »
Kończąc moje wypowiadanie się w tym temacie powiem tylko, że macie wolną wolę i to jest wasz wybór czy zainstalujecie IE8, czy pozostaniecie na IE6, tylko nie zdziwcie się później jak wam wyskakują jakieś dziwne błędy w programie, w obsłudze emotek, czy w obsłudze stylów czata... i nie zdziwcie się jak będzie takich błędów coraz więcej, a dowiedziawszy się że macie IE6 nikt takiego zgłoszenia o błędzie nawet nie obejrzy ;) Jak już wcześniej gdzieś w którymś wątku wspomniałem moje style okna rozmowy nigdy na IE6 testowane nie będą i nie sądzę żeby chociaż połowa z nich wyświetlała się poprawnie... nawet jestem gotów tak przygotować kod żeby na IE6 wszystkie style się wykrzaczały)
Mój głos w kwestii tych powiadomień o starej wersji IE jest po części zbieżny z waszymi poglądami tzn. jestem przeciwny takim komunikatom, w związku z czym postuluję całkowite zablokowanie instalacji wtw na maszynach wyposażonych w IE6.

Pozdrawiam ^^

Gratulacje podejścia. Z doświadczenia wiem, że większość koderów stara się dostosować swoje produkty do jak największej liczby odbiorców, niezależnie od oprogramowania. No ale widzę, że niektórzy jeszcze do tego nie dorośli.

Co do IE6, ten komunikat jest irytujący. Sam muszę pracować na systemie z IE6, jedyny ratunek to włączenie WTW rano, niech ciupie aż do wieczora. Oczywiście, że mam inne przeglądarki, IE7, IE8, FF, Opera, Chrome, ale wszystkie w wersji portable.

Jakoś nie zauważyłem, żeby w podstawowej wersji WTW (przy IE6) komunikator sprawował jakiekolwiek problemy, więc możliwość wyłączenia tego komunikatu (w jakikolwiek sposób - konsola, jakiś przełącznik, etc.) byłaby jak najbardziej wskazana - najlepiej w jakiś wymyślny sposób, żeby mniej ogarnięci użytkownicy nie zawracali głowy problemami, po dokonaniu przypadkowej zmiany.

Powtarzam, że w niektórych przypadkach stosowanie IE6 jest wymuszone odgórnie, i jeśli komunikator nie powoduje drastycznych problemów na starym tworze Billa, to nie powinien też irytować dziwnymi komunikatami. No chyba, że cała funkcjonalność pada, ale wtedy pisze się, że do działania potrzeba jest wersja IE7 lub wyższa itd.


Global Moderator Comment W IE6 jest problem z przewijaniem a "Zawsze Przewijaj" nie ziała tak fajnie jak przewijanie w nowych wersjach IE



« Ostatnia zmiana: Stycznia 27, 2011, 18:18:33 pm wysłana przez Vimes »

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Odp: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #54 dnia: Stycznia 27, 2011, 16:28:05 pm »
bugmenot... czy tworząc swój produkt MUSISZ się zmuszać do zadowolenia nim wszystkich? Pewien mądry Pan, czyt. kaworu, wpadł kiedyś na pomyśł napisania programu, zwanego dalej WTW, a następnie udostępnienia go innym. Czy ta dobromyślność ZMUSZA go do dostosowania WTW pod stare gówna (bo inaczej tego nazwać nie mogę) ? Podejrzewam, że udostępniając program pracował już przy nowszej wersji IE, więc nie miał zamiaru cofać się w rozwoju (przynajmniej nie dla siebie). Zatem... dlaczego WTW nie zadziała na Windowsie 3.1... dlaczego WTW nie mogę odpalić w DOS-ie? Aaaa... może jednak ten program był pisany pod nowsze systemy? A może jeżeli nie pod systemy to pod nowszy silnik przeglądarki, bo na IE się ponoć opiera... Gdyby rozwoj stanął i nie był aktualizowany pod nowsze produkty - można by powiedzieć o "trupie (ala konnekt)". Ale który program pisze się przeciwstawiająć upływającemu czasowi? Nie rozumiem Twoich pretensji do zhvira. Napisał jasno i klarownie. Również zablokowałbym możliwość instalacji na maszynach z IE6, bo ludzie mają potem pretensje co najmniej jakby za ten produkt zapłacili!

Offline bugmenot

  • Młodzież
  • **
Odp: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #55 dnia: Stycznia 27, 2011, 21:46:04 pm »
>>Global Moderator Comment
W IE6 jest problem z przewijaniem a "Zawsze Przewijaj" nie ziała tak fajnie jak przewijanie w nowych wersjach IE


Ok, ale ta niedogodność w niczym mi nie przeszkadza (tak jak niektórym osobom, które udzielają się na tym wątku), czego nie mogę powiedzieć o ciągłym wyskakiwaniu okienka z alertem o starej wersji IE - doskonale sobie zdaje sprawę, że w systemie siedzi ten syf, ale zmienić tego nie mogę.

Więc, powtarzam, jeśli przewijanie to jedyny problem WTW + IE6, nie powinno być problemu z wprowadzeniem ukrytej (niech będzie dla zaawansowanych) opcji wyłączającej alertu.

>>switalski.piotr
Czytaj ze zrozumieniem.

Offline switalski.piotr

  • Stylista
  • Starszyzna
  • *
Odp: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #56 dnia: Stycznia 27, 2011, 22:02:45 pm »
Wyłączenie tego ostrzeżenia sprawi, że użytkownik zapamięta o problemie z przewijaniem, ale daje sobie głowę uciąć, że znajdzie się taki, który napisze wkrótce:
"Cześć! Mam problem z Twoim stylem. Wyświetla mi wszystko w jednej linii. Co jest nie tak? Na innych stylach wszystko ok, więc pewnie musisz coś poprawić jeszcze" (a my potem szukamy problemów w niekompatybilnościach wtyczek, styli itd.)
Zapomni, że używanie IE6 może nie wpływać TYLKO na przewijanie, ale na szereg innych rzeczy. Ty uznajesz komunikat za zbędny, a ja uważam, że WTW powinno wspierać oprogramowanie na ktore zostało stworzone. W tej chwili masz firankę w drzwiach wejściowych (6). 7-->drzwi, 8-->z lepszym zamkiem, 9-->pancerne, ale jeszcze się zacinają. Nie widzę sensu upierania się przy starociach... styl retro akurat w tej dziedzinie się nie sprawdza.
« Ostatnia zmiana: Stycznia 27, 2011, 22:45:34 pm wysłana przez switalski.piotr »

Offline sjf

  • Narybek
  • *
  • TW Homer
Odp: Re: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #57 dnia: Stycznia 29, 2011, 20:45:58 pm »
To po co Ci w miarę aktualna Opera  można przecież używać 9.10 albo 9.26 albo po co Ci napalony lisek w najnowszej wersji(która nie jest zalecana przez mozillę) przecież mogłeś pozostać przy 2 ?
Jednak jest różnica - do aktualizacji Opery, Fx czy nawet Chrome'a wystarczy być ZU, spróbuj zaktualizować IE bez uprawnień admina to porozmawiamy.
PS. osobiście nawet potrafię to zrobić, ale co na to powiedzą admini w firmie to inna bajka...

Offline refresh

  • Grammarnazi
  • Global Moderator
  • Starszyzna
  • *
  • Ciasteczkowy Potwór :3
Odp: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #58 dnia: Stycznia 29, 2011, 21:21:04 pm »
teoretycznie mogliby Cię ścignąć już za samo uruchamianie programów nieistotnych w pracy/niezwiązanych z pracą/zewnętrznych, więc zmiana IE to w sumie to samo "przewinienie" co odpalenie wtw.

Offline kasper93

Odp: Używam IE6 - jak wyłączyć powiadomienie o błędzie krytycznym?
« Odpowiedź #59 dnia: Stycznia 30, 2011, 00:46:53 am »
Jest dokładnie tak jak mówi refresh, jeżeli nie macie możliwości aktualizacji IE, to z pewnością uruchamianie WTW też nie jest wskazane na takich komputerach. Po za tym wątek jest bezcelowy, bo nikt nie wspiera już ie6, a wręcz zaczynają go blokować (youtube, facebook itd.).  Jeżeli się mylę to podajcie mi konkretny powód dla którego w dzisiejszych czasach mielibyśmy wspierać ie6.
Zapraszam na kanał #wtw na irc.quakenet.org.
Logi http://wtwirc.fgfg.pl/
Nightly RSS http://wtwirc.fgfg.pl/ntly.xml